GD-77 Community CPS installer now includes OpenGD77 Comm driver

posted in: DMR, GD-77, Ham radio | 25

Jet another quick post with an update, but this time to the GD-77 Community CPS

I’ve modified the GD-77 Community CPS to include an option to include the Windows Comm port driver needed when using the Community CPS with the OpenGD77 firmware.

By default the CPS installer will run the driver installer when the main part of the installation is complete.

Please note since the CPS is run by default after the installer finishes, the CPS application will obscure the driver installation window. However because the driver installer does not have a user interface this does not affect the operation of the driver installer, it simply means you don’t see it installing.

If for some reason the driver installer fails, it may leave its installation window open, and show an error message, but since I’ve never had a problem with the driver installation, I don’t know for sure what happens under those conditions.

If a GD-77 running the OpenGD77 firmware is connected to the PC when the driver is installed, you should see the Windows notifications in the bottom right of the screen, showing the driver has been installed. However if the GD-77 is not plugged in etc, Windows will not complete the driver installation until you plug in or turn on the GD-77 which is running the OpenGD77 firmware.

The CPS installer should already request Administrator privileges if it needs them, and these privileges will also be used for the driver installer, because they are essential for the driver installation.

 

The installer is available for download from the usual location https://github.com/rogerclarkmelbourne/radioddity_gd-77_cps/raw/master/installer/RadioddityGD77CPS31XCommunityEditionInstaller.exe

 

For those who want to know the technical details.

Windows 7 or newer requires “signed” drivers, which has been a major problem to the open source community, because it costs a fortune each year for the certificate etc.
Fortunately Pete Batard thought of a way around this by writing a driver installer library   https://github.com/pbatard/libwdi, which I think creates a self signed certificate for the driver as part of the installation process, and thanks to some work done for the Arduino STM32 project (I’m sorry but I can’t remember who did the work), I was already in possession of a driver installer using libwdi specifically designed to install the USB Serial (USB CDCACM) device driver, which I was then able to reuse for use with the OpenGD77.

For the Arduino STM32 project, the drivers are installed using a Windows bat file, but in this case I’ve effectively put the part of the installation process handled by the bat file into the installer.

If anyone has problems with the driver installation, the driver installer is copied in the Windows Temp folder in a folder called OpenGD77CommDriver and is called wdi-simple.exe

If the driver installer needs to be re-run, this can be done my opening a Command Prompt (CMD) , changing to the %temp%\OpenGD77CommDriver directory and manually running the command

wdi-simple.exe –vid 0x01FC9 –pid 0x0094 –type 3 –name OpenGD77

 

25 Responses

  1. ken
    |

    thank you

  2. Jirka OK2JIQ
    |

    Hello I have on gd77 open firm. v is on 17. sept 2019, I instal last CPS edition instaler comunnity with driver. Connect gd77 and turn on station and windows devices and printers show new deviced “opengd77(com5)”, next then I start the program CPS itsh reports unconnected, RDST GD77 not comunication with programe CPS. I have win10 64 vers.
    I’ve tried to play the driver several times, but nothing has changed gd77;
    OpenGD77 its very fajn soft, make OK, only I have probleme with CPS. Jirka

  3. andre
    |

    Tks, very very good… But this wont work with new version of FW 3.2.4, right? It requires the new Soft. 3.1.8 (released this week, I believe).
    tks

  4. ok2jiq
    |

    Version 3.2.4 also works with CPS ver 3.1x community edition

  5. andre
    |

    wow, tks

  6. ecolive
    |

    Latest version is triggering windows 10 buil-in anti-virus

  7. SV3IBF
    |

    Hello Roger
    When downloading I am receiving virus alert for Trojan:Win32/Spursint.F!cl.
    Can you please check?

  8. Pierre-Antoine
    |

    Hello, everyone! So I updated my GD-77 first with Radioddity’s firmware 3.2.4. Using the CPS v.3.1.9. software, everything works perfectly.
    Then I performed a second update using Open firmware. Here again, the GD-77 works perfectly even in hotspot mode (congratulations to the whole team!).
    However, my GD-77 is no longer recognized either by using the Comunnity Edition or version 3.1.9 while the USB driver seems to work well in COM10.
    Any ideas?
    73′ de F6CYK

  9. Roger Clark
    |

    I’m not sure.

    Microsoft antivirus on my machine does not report any problems.

    Its possible the Driver Installer which is being reported as a problem.

    Which file does it report as the problem? The whole installer

  10. SV3IBF
    |

    Hi Roger, Yes, it’s the whole installer

  11. Pierre-Antoine
    |

    Hello Roger !
    No problems are reported by the Windows 10 system. Everything is normal.. In the device manager, the “OpenGD77” driver (COM10) is perfectly recognized and is indicated as working normally.

    Just an impossibility to recognize the GD-77 with CPS Community Edition or CPS software v.3.1.9 with Open firmware installed when there is no problem with the Radioddity firmware v.3.2.4 and CPS software v.3.1.9.

  12. RiKu Bister
    |

    write email to you about this

  13. Roger Clark
    |

    I’ve rolled back the installer on Github to the previous version as a precaution.

    I’ve scanned the file using several different antivirus programs, but none of them are reporting a problem.
    I’m updating my Windows 10 machine in case its antivirus is out of date, and I will double check when that machine has fully updated.

    I scanned my whole PC and it did not find any active viruses. But it did find the BlueDV “test” installer, which I downloaded, which had a virus in it. I don’t think I installed the “test” version of BlueDV – but I can’t be 100% sure.

    I tried submitting the installer exe to Kapersky’s virus desk “https://virusdesk.kaspersky.com”, and it did not find any problems

    I also checked the driver installer file wdi-simple.exe using the same online service and it didn’t find a problem with that file either.

    I tried it on another online virus scanner, which is supposed to scan using multiple antivirus engines, and this claims to find 2 potential problems but these are not the same problems that people are reporting and the 2 antivirus engines that find the problems are not mainstream, and I’m not sure I trust the results

    https://www.virustotal.com/gui/file-analysis/ZTFlNWExMzU3YzZiNTgzMWUxYWJkMzhmN2QxZTJjMGU6MTU2OTIwNDQ3Mw==/detection

    I can’t really resolve this problem unless someone can find me an online scanner which reports the same problem that Windows is reporting.

    I could perhaps just make a small change to the installer and re-run it, and perhaps the code would then not appear to have a virus.

  14. IW6CNM Davide
    |

    Hi Roger
    thanks for development !
    i have the same cps connection problem , the cps comunity edition installer completed without error and the serial OpenGD77” driver too , but cps couldn’t find the device ( open firmware installed ) , tested on W7 and W10 machine with same result.
    aanyway great job !

  15. F6CYK Pierre-Antoine
    |

    Hi Roger! Thank you for all your efforts and work.
    Here I have no problem with the antivirus but the GD-77 is indicated as “not recognized”.
    However, I can read and write the data via the “Extras/OpenGD77 Support” menu but I can’t load the DMR IDs (“Device not found”).
    Congratulations for the great job!

  16. Rubens
    |

    Hi Roger
    After I installed the open firmware, the GD-77- community cps not longer find the radio, I tried to reinstall the driver several times but it doesn’t make any difference. I can see the usb programming in com-9 every time the radio is on, but the cps will not find it.
    Reinstall the CPS and nothing, but if install the last firmware from radioddity, no problem, I can read and writte.
    Installed the open-firmware and with GD-77 community can not find the radio, not even trying the support option.
    I,m using windows 10, tried as an administrator but the same result.
    any help will be apreciated.
    Thanks
    Rubens / KA6VHA

  17. Roger Clark
    |

    See chapter 11 in the manual

    https://raw.githubusercontent.com/rogerclarkmelbourne/OpenGD77/master/docs/Open%20GD77%20User%20Guide.pdf

    Also on W10 check the device manger that the OpenGD77 device is being shown by name in the com ports.
    If not you need to uninstall windows own unnamed driver and install the named OpenGD77 driver, otherwise the CPS won’t find it

  18. F6CYK Pierre-Antoine
    |

    Hello Roger, the OpenGD77 device is well displayed by its name in the communication ports. It is “partially” found by the CPS since the “Extras/OpenGD77” menu allows you to read and write the codeplug but it is not found by the Read an Write commands on the banner.
    Same for the Calibration viewer and DMR ID.
    Thank you for the great job!
    73′ de F6CYK

  19. Roger Clark
    |

    The buttons on the banner are for the official firmware only. There are 2 completely different comms protocols

    Re: Calibration

    Likewise. That only works for the official firmware. The OpenGD77 does not support changing of the official calibration data.
    This is partially because we don’t use much of the official calibration data

  20. carlos
    |

    Roger, First of all, congratulations from Mexico for your contributions to the amateur radio. Like other hamradio I have problems to be able to read or write in the gd77 when it is updated to your latest firmware version and with the opengd77, I use win7 and if the driver has been correctly installed correctly and it appears with the corresponding name. I have tried to delete and reinstall the driver and software, change the com port number and when running the software and want to read or write the radio, the error message is not found.

    Also when using the gd77 in radio mode (not as a hot spot) and connected to a local dmr repeater, I always listen to a tg that is not selected, and it doesn’t matter if the group changes, I still listen to the one that is not selected, so I know you are busy but I would like to ask you if there is a way to solve this, or when updating your firmware, is the radio useless to be used through a repeater? Can we only use it to connect to a hotspot or use it as a hot sopot?

    Really thank you very much

    XE1GLY MEXICO

  21. Roger Clark
    |

    TG filtering will be added later, and will be an option, because not everyone wants it.

    Tier2 is now in early beta and does work for Rx and Tx, but needs a more work before it can be made available

    W10 does work, but the default driver must be uninstalled, while the radio is disconnected. The OpenGD77 then installed , and the radio reconnected

  22. Robert Fullarton
    |

    Try using this command to install the driver.

    “%~dp0wdi-simple” –vid 0x01FC9 –pid 0x0094 –type 3 –name “OpenGD77” –dest “%~dp0OpenGD77-serial-driver-files”

  23. Roger Clark
    |

    Thanks

  24. Angel, EA5JN.
    |

    Good Roger Thanks for all the work but I need a solution under windows 7 the cps comuniti edition does not connect the radio driver problem thanks for the job a Greeting EA5JN.

  25. Roger Clark
    |

    Do you mean it does not connect to the OpenGD77.

    Did you download the driver zip file and install it ?

Leave a Reply