GD-77 Community CPS – initial OpenGD77 support features

posted in: DMR, GD-77, Ham radio | 23

Just a quick post for anyone testing the OpenGD77 firmware

I’ve now finished adding some initial support for the OpenGD77 into the Community CPS, and I’ve created a special version of the installer for the version with these features, which can be downloaded from here

 

https://github.com/rogerclarkmelbourne/radioddity_gd-77_cps/raw/OpenGD77_Comms/installer/RadioddityGD77CPS31XCommunityEditionInstaller.exe

This version also still supports the official firmware, using the normal Read and Write buttons on the main screen

 

 

As well as the updated installer, you will need to install a driver, because the OpenGD77 operates as Serial USB device.

The 2 files that are needed to install the driver are here

https://github.com/hamdv/OpenGD77/tree/master/OpenGD77CommDriver

 

Once the driver is installed, the Windows device manager should show the “OpenGD77” in the “ports” section.

 

In the CPS , there is a new menu item under the Extras menu for OpenGD77 Support, which opens this window

 

From here you can backup, both the internal 64k EEPOM and the 1 mega byte Flash chip, as well as Reading and Writing the codeplug.

Before Writing a codeplug to the radio, you should backup both the EEPROM and Flash chip, and save the files somewhere safe, in case something goes wrong in the future and you need to restore the data.

 

To read the codeplug,press the “Read codeplug” button, wait for all 3 data sections to download, and then close the OpenGD77 Support window.

To write a codeplug, First put the radio into FM mode, by pressing the star key if you are in DMR mode, on either the Channel or VFO screen.
Then just press the “Write codeplug” button.

 

If you change the VFO settings, you’ll then need to go into the Utilities menu and select the option to do a “Fact reset”, as this is currently the only way to reload the VFO data into the non-volatile settings that the firmware uses.

 

DMR ID support has also been added, in the DMR ID window, where there is an extra button at the bottom, labelled “Write to OpenGD77”

 

 

Currently there is no indication in the OpenGD77 firmware that the codeplug is being read or written, but I think we’ll need to add a screen like the official firmware has, and we’ll also need to have a better way to reload the VFO paramaters from the updated codeplug.

 

 

At the moment, things are bit untidy, but at least it works, and I’ll clean up the user interface at a later date when I don’t have so much programming to do on the OpenGD77 firmware itself.

23 Responses

  1. Jørn
    |

    Installed and tested, this is getting very good Roger.
    73
    Jørn

  2. Roger Clark
    |

    Jørn

    Can you tell me what version of Windows you are using, because someone using Windows 10, seems to be having some problems.

  3. ken
    |

    thank you

  4. Matthew Fairbairn (M6SEU)
    |

    Cannot get the CPS to connect to radio in Windows 7. Com port 13 is GD77. When switching on radio detect sounds are correct.
    Working on it will lt you know when iv’e fixed it.
    Matt

  5. Roger Clark
    |

    Hi

    In the Windows device manager does the GD-77 show up as “OpenGD77”, if not the driver is not being loaded correctly and the CPS won’t work because it looks for that name

    I’ll email you directly.

  6. Jørn
    |

    Roger
    I am using Windows 10, No problems here so far.

  7. Roger Clark
    |

    Thanks

  8. Matthew Fairbairn (M6SEU)
    |

    Hi Roger.
    All working both on Win10 Pad and Win7 Laptop now.
    Many thanks.
    Cheers Matt.

  9. Roger Clark
    |

    Thanks for letting me know.

    PS. I did get your emails, but have not had time to reply

  10. Hans
    |

    I installed it as portable version on my usb stick (using Portableapps). Running in Windows-7 and Windows-10 without any problems so far.
    The only thing, I did personally not understand, is the difference between the two contact lists “DMR-ID” and “contacts”. Do they both the same or is there a difference between them? If yes, which one is preferred for which purposes?
    Sry to ask, do not want to bother.
    Ah, and yes: Great work!

    Thanks a lot

    best Hans (DL4OCJ)

  11. Roger Clark
    |

    Originally in order to display the callsign and name of a station you are receiving, the callsign and name have to be entered into the Digital Contacts part of the CPS, but this is limited to a max of 1024 including TGs

    Radioddity then introduced a separate system called DMR ID, which stores up to 10920 callsigns (but not names), in a separate part of the 1Mb flash memory of the radio.

    Hence I had to add a feature to the CPS to handle the separate DMR ID database system.

    The problem with the DMR ID system in the official firmware, is that they only allowed 8 characters per DMR ID, which is only enough to store the callsign and perhaps an initial letter.

    So I had to modify / hack the firmware to increase that allocation to 16 characters, and I managed to find a bit more memory that Radioddity were not using, and managed to increase the number of callsigns and names that can be stored.
    However, I have not generally released that hacked firmware because it is always a risk for people to use non-official firmware

  12. ESTEBAN PRADO
    |

    Please good morning from Spain / Alicante could you tell me the latest advances in this beta firmware. Thank you

  13. Roger Clark
    |

    The CPS can now read and write the codeplug to the OpenGD77 firmware, as well as backing up and restoring all of the EEPROM and Flash chips in the GD-77 (when its running the OpenGD77 firmware)
    The CPS can also upload the DMR ID database to the OpenGD77 firmware, but its not able to read back the DMR ID database from the radio, as I didn’t feel it was a feature that ever gets used.

    If you mean the actual OpenGD77 firmware. I will to write an update blog post about the OpenGD77 firmware, as there have been a lot of enhancements, But… DMR Tier 2 is still not supported.

  14. Carlos
    |

    Hola, viendo tus comentarios de open GD 77 y con ánimo de ayudar, lo acabo de instalar.

    He puesto el driver y veo el puerto, pero el programa de leer el walkie no me lo detecta, a ver si me puedes ayudar.

    Tengo una rsspberRa 3B +

    Si puedo ayudar en slgo dímelo. Un saludo, soy EA1HYZ Carlos.

  15. Roger Clark
    |

    The latest version of the Community CPS has an extra screen to read and write the codeplug, and an extra button on the DMR ID screen to upload to the OpenGD77 firmware

    P.s. you can always reload the official firmware, as the OpenGD77 does not many any changes to the radio etc

  16. Paco Romero EA5III
    |

    Hi Roger, congratulations for your great job. I have a problem with the drivers. Using Windows 10 , version 1709. It appears a new USB COM port with a number. It does not show OPENGD77, so the CPS displays the message I need to connect an OPENGD77 device. And does not work.
    73

  17. Roger Clark
    |

    Aaarrghh..

    Windows 10 🙁

    The driver gives the port a name so that the CPS can automatically find it, without the need for the user to select a port.

    Did you load the driver using the bat and exe file ?

    I am pretty sure the Beta tester used W10 and no one else reported this problem

  18. Paco, EA5III
    |

    Thank you for your fast answer, Roger. Yes I do. I used the two booth (bat and exe). I don’t Know if one of them must be the first one. Anyway I tested the two possibilities. One thing that called my attention was the exe file open a new window and works for a time and we can see some messages on screen. In the other way, the bat file shows only a short flash screen that disappears and seems to do nothing. I don’t Know if it is the expected behavior .
    TNX again
    73

  19. Paco, EA5III
    |

    hello Roger, thank you for your early response. Yes I do. Installed the two both files. I don’t know if any of them must be installed the first. Anyway I tested the 2 possibilities. When I install the exe file it opens a new window with some working messages. When installing bat files it flashes a screen and disappears. I don’t know if this is the expected behavior.
    TNX AGN
    73

  20. Roger Clark
    |

    You only need to run the Bat file.
    The bat file controls the exe.

    Try running the bat file as the administrator, i.e right click and chose Run as administrator

    Btw.

    You need to put those files somewhere like your Documents folder, because the exe unzips some files it uses to install the driver.

  21. Ray C
    |

    I have the same issue. After running the batch file on windows 10, i now have an OpenGD77 (COM5) in my device manager, that the CPS Community edition won’t talk to. 🙁 Any suggestions?

  22. Roger Clark
    |

    Did you look in the Extras -> OpenGD77 Support screen.

    The existing buttons on the main screen only connect to the official firmware

    I probably need to get those buttons to open the OpenGD77 support screen if the OpenGD77 is detected on a Com port, as this seems to be causing some confusion

  23. Ray C
    |

    Oh, I’m a dumb. That works perfectly, thanks!

Leave a Reply