Radioddity GD-77 Community CPS for firmware 3.1x

posted in: c#, Ham radio | 23

For anyone who wants to download the latest version of the GD-77 Community CPS , please use these links


For anyone using the old firmware (version v 3.0.6 ) please use this installer


For anyone using the latest firmware version 3.1.0 to 3.1.8  etc , please use this installer


[End of Update]

____________________________ Original post begins here _____________________________________


As some of your already know, with the help of Colin G4EML, I’ve published a Beta (development) version of the GD-77 Community CPS to support firmware versions 3.1.x.

This covers firmware 3.1.0 beta, 3.1.1 official release and 3.1.2 beta.


The new version of the CPS can be downloaded from here


At the time of writing I know about 20 people have used it without any problems


This version of the CPS will upgrade a 3.0.6 codeplug if necessary, and will show a popup message if it needs to upgrade.


The main changes to the official CPS 3.1.1 is the re-organisation of the memory used to store the Rx Group Lists.

Rather than a maximum of 128 Rx Groups, each of 15 Contacts (TalkGroups), the new arrangement is a maximum of 72 Rx Groups, each of up to 32 contacts.

Radioddity also removed a “reserved” byte in the RX Group data, which they were not using, probably to squeeze the total number of groups a bit higher e.g. to 76 rather than 75, but I can’t really see how this would effect most users.

The result of this, is that anyone with more than 76 Rx Groups will not be fully upgraded and you will manually need to change your codeplug to suit you needs. However I don’t think this will impact on Amateur Radio uses as most people only have a few Rx Groups


The other new feature is the Scan time setting on “Scan Basic” form. I can’t remember the precise details of what this function does, as I don’t do any scanning myself.


Radioddity also removed some redundant (irrelevant) settings relating to the Scan function from the VFO form, so we’ve removed them from this version; and as they were actually irrelevant for firmware 3.0.6 I’ve also updated the 3.0.6 CPS to remove them.


There are some improvements in the official CPS which I have not had chance to implement in the Community CPS yet.

Specifically, when deleting contacts or channels, the official CPS seems to do some compaction. The result of this, is that when deleting a Contact from the middle of the list, in the official version, and then adding a new Contact; the new Contact goes at the end, where as in the Community CPS the new Contact goes into the space vacated by the Contact that has just been deleted.


I will update the Community CPS when I have time, so that it does this, however at the moment, my focus is on the Flash Manager, which I wrote for Jason (VK7ZJA) with the help of Colin G4EML.

And I think at the moment that getting Flash Manager to be able to Read, Display and Save the calibration data is higher priority than small improvements in the CPS.

Also at the moment there isn’t an installer for Flash Manager, so the files have to be copied manually to a folder etc.


At the same time I am still making GUI improvements to the Community CPS if I am told about something which won’t take me long to fix e.g. Douglas (DF4DQ) noticed that the ListBoxes for the Rx Groups, were not wide enough to fix the maximum length Contact name, so I have already modified this, and I will update the installer version later today.


One more bit of unrelated news

Ty Weaver, of MD-380 fame has replied to a question I posted on the MD-380 tools group, and suggested some tests that I can perform on the firmware update file, which may reveal how its encypted, so I will probably spend some time today, writing some software to explore his idea, as being able to modify the firmware on the GD-77 like can be done on the MD-380 is also on my “To Do” list!msg/md380tools/cK1KpBgI1WE/C0LV9LsNCgAJ

23 Responses

  1. Manu

    Gracias por toda la información. Lo probaremos.
    Recordar de que hay que hacer un esfuerzo para lograr que el equipo G77 pueda trabajar con varias ID diferentes. Sólo deja un ID.

    Google translated to

    Thank you for all the info. We will try it
    Remember that you have to make an effort to get the G77 team to work with several different IDs. Just leave an ID.
    Thank you

  2. Thierry

    I use the CPS community 31x for 2 days to go from 306 to 311 and no problem.
    Thank you for your great work!

  3. ken

    great work, I was waiting to install 3.12 beta until you published this. so far all is ok here, thanks very much for your work.

  4. Roger Clark

    Thanks for the feedback

  5. EvO

    I used your CPS community 3.1.x to go from 3.0.6 to 3.1.1 on my GD-77 3.1.1 and no problem.
    I wrote up in my GD-77 a pretty huge amount of channels and frequencies and all is working great, awesome job Roger!
    In order to make thing easy I compiled my own codeplug using the utilty GD77-CSV(3-1-X) by Colin G4EML.
    On that side I noticed that weirdly CVS provided by the Colin’s utility adds ‘ (apostrophe) before digits when item start with a number (i.e. 2Hornet became ‘2Hornet).
    I know that this isn’t the right place to put this information, however I take the opportunity to disclose the fact here.

  6. Roger Clark


    I have emailed Colin about the problem



  7. Murray

    Thanks Roger for your work. When I updated to 3.1.1 the talk permit tone no longer works whether I use Radioddity CPS or your CPS. I have talk permit tone checked in the general setting. I also had the 220 MHz working but now lost it when firmware upgrade done. Haven’t tried to redo the extended frequency yet with new firmware or software. Any suggestions?

  8. Roger Clark


    I can’t remember if Radioddity fixed the talk permit tone.

    I remember Jason VK7ZJA checking if the bug was fixed, but I can’t remember if it was.

    See Jason’s comment in this post

    Also, I”m not sure about 220Mhz, I don’t use it, so have not tried to use it after updating

    Check the general settings in my CPS, as these are read from your codeplug, and I normally use

    UHF 400 – 520
    VHF 130 – 400

    (Some people use VHF 136 – 400 because using 130Mhz causes a factory reset on their GD-77 but we don’t know why)

  9. Murray

    Got the 220 and extended frequency working now. I don’t know about the admit criteria if it’s been fixed or not but the talk permit tone doesn’t work in
    FW 3.1.1.

  10. Roger Clark


    As far as I can tell, by reading Jason’s comment. The Talk Permit tone probably still has bugs.
    He has not listed it as a bug that has been fixed in 3.1.1

    I don’t know if he’s tested it in 3.1.2 (Beta) but I this version possibly only has an additional bug fix for the factory reset data problem (which causes low Tx power)
    I did ask Radioddity what’s changed in 3.1.2 but they said “Bug Fix”, so I’m none the wiser 😉

  11. Murray

    I was not aware that there was a bug in the talk permit tone since it always worked on my radio in all previous versions. I have my admit criteria set to always.

  12. Roger Clark

    Checking my bugs list post…

    I see that the talk permit tone bug was introduced in 3.1.0 and it sounds like its not been fixed yet.

  13. Murray

    It seems every time a new firmware version is produced, some new bugs are introduced. Well, that’s progress, sort of.

  14. John Hein

    One change to your CPS which would be useful would be to allow the ordering of Channels to be able to be changed in the same was as Zones.

  15. Roger Clark

    That’s on my To Do list, but the Flash Manager is higher priority at the moment (and taking several hours work per day), as it has allowed people to resurrect broken GD-77’s that could not be fixed by downgrading to firmware 2.6.6. etc

    With the help of Jason we’re hoping to add a Calibration screen to the CPS, like the hidden feature on the MD-380 CPS, however its early days as there is no documentation on the function of the memory addresses that store the calibration, so Jason is having to figure it out by trial and error

  16. Colin G4EML

    Regarding the talk permit tone, it has never worked correctly on DMR repeaters. It beeps as soon as you press the PTT even if the repeater is out of range. Because it doesn’t work properly Radioddity have disabled it in the latest firmware. It will re-appear when the bug is fixed.

  17. Roger Clark


    Thanks for the clarification

  18. chaplinhugo

    Here, the 220 works but only in FM. Test carried out only between 2 GD-77 not allowing to know the spectral purity on this band and the power …

  19. Roger Clark

    I think Jason VK7ZJA did some Tx tests on 220Mhz but I can’t remember the results.

    Perhaps if you have a USB RF receiver dongle, you could investigate the purity

  20. Fowler Johnston

    Tried to download the beta CPS antivirus stopped it saying “Trojan virus”

  21. Roger Clark

    The software is open source. So you can rebuilt it yourself.

    All the sources are available here

  22. Fowler Johnston

    Corrected and downloaded Thank you!

  23. Roger Clark